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1 Introduction

First, thank you for purchasing HugePlayground: Post Apocalyptic.
HugePlayground: Post Apocalyptic documentation contains everything you need to get started.

The asset is designed to create large map that's why the asset uses the scene additives system.

Additives scenes:
-To calculate lightmaps on a large scene, the demo scene is separated into several scenes. These 
scenes are recombined together in the hierarchy tab. Scenes are load additively.
Using additives scene system causes some constraints.
Read chapter 3 ,4 ,5 and 6 carefully to understand how to use additive scenes and adapt them to 
your project.

If you don’t want to work with additive scenes and want to combine the demo scenes into a single scene 

read this tutorial : Link

Performance:
The demo scene includes a lot of prefabs. This is why it is necessary to optimize.
A script is included in the asset that makes some of the objects hide and unhide depending on the 
distance from the character.

For more informations about optimize scripts: Link

Something else to know

Procedural:
A script allowing to create procedural elements is included in the asset.
Script allows to create roads, electricity pole, fences and crash barrier.

For more informations about procedurals:  Link

Prefabs :
To discover all prefabs contained in this asset open scenes: 

Assets > HPA > Scenes >  Showroom  > Showroom_Prefabs_Buildings
Assets > HPA > Scenes >  Showroom  > Showroom_Prefabs_Objects

For more informations about prefabs  : Link     

How to start:
-Read chapter 2 to setup correcty the asset : This settings are needed to use this asset. Link

Caution: Don’t forget to install URP package.

If the prefabs are pink when you open the demo scene, this means that URP Package is not 
installed or configured correctly.



If you have the following error message: the type or namespace name universal does not exist...
This means that URP Package is not installed.

If you do not have URP installed, other error messages may appear in the console. Install URP to 
make console errors disappear.

-Read chapter 3  to learn how to test the demo scene and integrate your project. Link

-Read chapter 4  to learn how export a build with additives scenes. Link

-Read chapter 5  to learn basics about working with additives scenes. Link

-Read chapter 6  to calculate lightmaps with additives scenes. Link

-If you have a problem read chapter 17 Troubleshooting Link

If you have any questions, please contact us at tropicalstudio3d@gmail.com  



2 Settings

1 Go to File > Build_Settings.

Verify that PC, Mac & Linux Standalone mode is 
selected.

2 Installing unity Project on SSD disk

The asset is designed for use with additive scenes. 

Using additive scenes increase the opening and 
closing time when you press play/stop in editor.
This is why it is advisable to install the project on 
your SSD disk to reduce this time if you can.
Installing unity Project on SSD drastically speedup 
the opening and closing time when you press 
play/stop in editor.

For more information about additives scenes Link



3 If you haven't already had it, installed URP 
(universal render pipeline)

Go to Window > Package Manager

4 -Choose Unity Registry (spot 1)

-Choose Universal RP (spot 2)

-Press Install button (spot 3)

5 In project settings tab:
Select Graphics 
From project tab drag and drop 
UniversalRenderPipelineAsset to scriptable Render 
Pipeline Settings slot

 Assets > HPA >  RenderPipeline > 
UniversalRenderPipelineAsset

6 In Project settings tab:

-Select Player
-Set Color Space to Linear



7 In Project settings tab:

-Select Quality
-Set Lod Bias to 3 

8 In scene tab: (spot 1)

-Press grid button (spot 2)

Set Move X to 1.5  (spot 3)     
Set Move Y to 1.5           
Set Move Z to 1.5         

Set Rotate to 90 

9 In Project settings tab:

-Select UniversalRenderPipelineAsset_Renderer 
(spot 1)
 Assets > HPA >  RenderPipeline > 
UniversalRenderPipelineAsset_Renderer

In Inspector tab:
-Check Enabled Checkbox  (spot 2)

10 SSAO (Screen Space Ambiant Occlusion):

SSAO uses a lot of resources so you can disable it if 
you wish.

To deactivate it:
In project tab select: Universal Render Pipeline 
Asset_Renderer (spot 1)

In Inspector tab uncheck Screen Space Ambiant 
Occlusion checkbox (spot 2)



3 Prepare your project

Important:
To be able to calculate lightmaps on a large scene, the demo scene is separated into several 
scenes. These scenes are recombined together in the hierarchy tab. 
Scenes are load additively.

To set up the demo scenes we will place all the necessary scenes in the hierarchy tab

 

Configure demo scenes 

In Project tab double click on Gameplay_Scene  to 
open it (spot 1)

Assets > HPA >  Demo > Gameplay_Scene

Info: Gameplay_Scene contains all the gameplay elements

To Go further

If you want to configure the demo with additional features 
(minimap,new locations feedback, shortcut info, FPS counter and 
sun movement):

-instead of Gameplay_Scene use Gameplay_Scene_Full
Assets > HPA > Other >Scene_Full  > Gameplay_Scene_Full

Caution: These features are only there as an example. These 
features are not explained in this documentation.

If you want to deactivate these features:
-disable DEMO_Grp

If you want to delete these features:
-delete DEMO_Grp

Important:
If you use Gameplay_Scene_Full
you must set Gameplay_Scene_Full as active scene
For more information about set active scenes Link

If you don’t set Gameplay_Scene_Full as active you may have the
following error message:
NullReferenceException: Object reference not set to an instance 
of an object.



In hierarchy tab: 
From project tab drag and drop Procedural scene to 
the hierachy tab.

 Assets > HPA >  Demo > Procedural

Info: Procedural contains all the procedural objets.
These procedural objects are roads, electricity pole, fences 
and crash barrier.
This procedural objects have been created with a script.
The script is included in the asset.

For more information about the procedural script Link

In hierarchy tab it is possible to drag and drop several 
scenes at the same time.

From project tab drag and drop
Zone 01 to Zone 09 to the hierarchy tab

Assets > HPA >  Demo > Zone_01

Info: Zone 01 to Zone 09 contains terrains, objects and 
buildings of each aera

Press Play to start the demo.

The first time you start the demo, error messages may
appear.

Do not take this warning into account.

Using additive scenes increase the opening and 
closing duration when you press play/stop in editor.

Don't be surprised if the first time, the scene takes 1 
minute 30 to open.

Afterwards the scene takes around 20 seconds to 
open / close.
 
A tip is presented at the end of this chapter to speed 
up the opening and closing time.
For more information about the tip Link



Shortcuts:

E,S,D,F  to move
Hold Shift (Maj) to Run
Press Space bar to Jump
Press C to crouch
Press ESC (Echap) 

Press ESC (Echap) 
Press Play again to stop the demo.

Integrate your own gameplay elements

If you have gameplay elements from your project, 
copy them into the scene Gameplay_Scene

For some reason if you don't want to copy your gameplay elements into 
Gameplay_Scene follow this step:

-From project tab drag and drop your gameplay scene to the hierarchy tab

To export a build:
-Add your gameplay scene in the build window
To learn how to setup build window Link
-Setup LoadAdditive scene to add your gameplay scene to the list.
To learn how to use and setup LoadAdditive scene Link

Follow this steps to copy your own gameplay 
elements into   Gameplay_Scene  :  

1 From project tab drag and drop your gameplay 
scene 
to the hierarchy tab



2 In hierarchy tab:
From your gameplay scene drag and drop elements in
Gameplay_Scene

3 In hierarchy tab select Gameplay_Scene:
-Mouse right click (spot1)

-Choose Save Scene (spot2)



4-In hierarchy tab select your gameplay scene
-Mouse right click (spot1)

-Choose Remove Scene (spot2)

5 A new window appears

-Press Don’t Save button

Use your own character controller 

If you want to use your own character controller follow
this steps:

1 In hierarchy tab:
-In Gameplay_Scene delete Grp_CharacterCamera



2 Add your character controller into Gameplay_Scene

3 To use the optimization system you must attach the 
optimization script included in the asset to your 
character

Important:
The optimization system hide or unhide prefabs depending 
on the distance from the player position.
A script must be attached to the character.
This script is included in the asset.

For more information about optimization script  Link

In hierarchy tab select your character controller

4 In Inspector tab press Add Component button

5 In text field type TS

6 Choose TS Character Tag in the list

Optimize script is now attached to your character 
controller

Other important things to know about additive 
scenes

Calculating lightmaps with additive scenes requires 
calculating the lightmaps of each scene 
independently.
To facilitate this process, a script is included in this 
asset

For more information about lightmaps script  Link



Using lightprobes with additive scenes requires adding a 
script that recombines them at start.

This script is included in this asset.
The name of the script is Init_LightProbes.
The script is in Gameplay_Scene and 
SK_Gameplay_Scene

For more information about lightprobes recombine script Link

Create a build with additive scenes

When using additive scenes, it is necessary to load all
the scenes at start

Chapter 4 is entirely devoted to this subject.
For more information about build Link

Environment parameters with additives scenes

When using additive scenes, use same environment 
parameters for all scenes.

Create your own map

If you want to create your own map from scratch, a 
starter kit is available to easily get started.

For more information about create your own map  Link



Speed up the opening and closing time when 
play/stop

This tip speeds up the opening/closing when you 
press the play button but:

-not all scenes elements are reloaded which ma  y   
cause visual bugs or other issues.
-on the other hand it can be hepful if you want to 
quickly test an element of gameplay

 To speed up the opening and closing time when 
play/stop is pressed do this:

Go to Edit > Project Settings

In project settings Tab:

-Select Editor (spot 1)

-Check Enter Play Mode Options Checkbox (spot 2)



4 Create a build with additives scenes

Overview

When working with additive scenes it is necessary to create a scene that will load all the scenes 
of the game at start.
As shown in the image below the scene LoadAdditives will load the scenes Gameplay_Scene, 
Procedural, Zone_01 to Zone_09

LoadAdditives scene is included in the asset.

How to setup the build

Go to File > Build Settings



From Project tab drag and drop scene 
LoadAdditive to the Build settings tab.

Assets > HPA > Demo > LoadAdditive

Very Important:
LoadAdditive must be positioned first into the list.

In the same way drag and drop the followings 
scenes:

-Gameplay_Scene
Assets > HPA > Demo > Gameplay_Scene

-Procedural
Assets > HPA > Demo > Procedural

-Zone_01
-Zone_02
-Zone_03
-Zone_04
-Zone_05
-Zone_06
-Zone_07
-Zone_08
-Zone_09
Assets > HPA > Demo > Zone_01

To Create the build:
Press button Build 

Info:
The first time the build compute time is much 
longer.



Adapt LoadAdditive scene to your project

LoadAdditive loads all the scenes needed when
unity open the build.

If you need to add new scene or remove  a 
scene follow this step

1 In Project tab double click on LoadAdditive to 
open it (spot 1)

 

Assets > HPA > Demo > LoadAdditive

2 In hierarchy tab select LoadManager 
(spot 1)

3 Open scenes list by pressing triangle button 
(spot 2)

4 Modify the Scenes List number
(spot 3)

Increase the number increase the number of slots.
Lower the number reduce the number of slots.

4 Finally, write without error the name of the 
scenes into the field Element (spot 4)

Very Important:
Put the scene that includes gameplay elements 
at the end last in the list. In this case 
Gameplay_Scene

Gameplay elements must always be loaded last in 
the list.

Important
Don't forget to remove LoadAdditive from the 
hierarchy tab.
If you do not remove LoadAdditive then press play, 
the game will not start.



Launch the game from your start menu

As shown in the image below, we will add a start menu.

When the start button is pressed:
- MainMenu is destroyed
-LoadAdditive scene is loaded
-LoadAdditive scene loads all the scenes necessary for the game.
-Once all the scenes have been loaded, LoadAdditive scene is destroyed.

For example, MainMenu scene is included in the asset.

-Open Build window
-Add MainMenu to the build list

Assets > HPA > Scenes > MainMenu

Very Important:
MainMenu must be placed first in the list

To go further:
If you want to learn more about loading the 
game from a start menu Link



5 Work with additives scenes basics

This chapter is intended for people who have 
never worked with additive scenes.

He explains how:
-save a scene
-transfer elements from one scene to another 
scene
-make a scene active

Remove a scene in hierarchy tab

If you want to remove a scene in the hierarchy:

-In hierarchy tab select the scene
-Mouse right click
-Choose Remove Scene

Save a scene in hierarchy tab

If you want to save only one scene in the 
hierarchy:

-In hierarchy tab select the scene
-Mouse right click
-Choose Save Scene



Save all scenes in hierarchy

If you want to save all scenes at the same time  
in the hierarchy:

-In hierarchy tab select the scene
-Mouse right click
-Choose Save All
or 
-use keyboard shortcut : CTRL + S

Make active a scene

Important:
New prefabs or elements are always imported 
into the active scene.

When you add a new prefab in the hierarchy 
tab, the prefab is placed in the active scene.

To make a scene active:

-In hierarchy tab select the scene
-Mouse right click
-Choose Set Active Scene

Info:
when a scene is set active:
In the hierarchy tab the name of the scene is in bold

Transfer elements from one scene to another

-In the first scene, select one or more elements 
(spot 1)

-Drag and drop into the second scene (spot 2)

-Save both scenes

Important:
If you transfer prefabs from one scene to 
another scene, it will be necessary to 
recalculate the lightmaps of the 2 scenes



6 Calculate lightmaps with additives scenes

Overview

When using additive scenes, you have to calculate the lightmaps for each scene separately. 
For this it is necessary to follow a special process.
To simplify this process a script is included in the asset. It allows to easily calculate lightmaps 
with additives scenes.

If you don’t want to use the script to calculate lightmaps read chapter : L  ink  

Important: 
In rare cases, if there is a crash during lightmaps 
calculation, some scenes may be corrupted. It is 
therefore prudent to make a copy of the scenes 
before calculating the lightmaps.

Setup the script

Go to Tools > HP > Calculate Lightmaps

Info: In the image on the right, we used the demo 
scene as an example

-First, put the scenes you want to calculate in the 
same folder.

-Write without error the path of the folder 
(spot 1)

Important: 
Don’t forget to add slash (/) at the end of the path
Example: Assets/HPA/Demo/

-Write without error the name of the scene in 
which directional light(Sun) is located
(spot 2)

-Write without error the name of the directional 
light(Sun)  (spot 3)

-If you want to add a scene or remove a scene you 
can modify the scenes number
(spot 4)
Increase the number increase the number of slots.
Lower the number reduce the number of slots.

-Finally, write without error the name of the scenes
into the field List of scenes (spot 5)



-Click on the button corresponding to the 
scene you would like to calculate

Each button allows to calculate one of the scenes.

Example: I want to calculate the lightmaps of the scene 
Zone_01

What does the script do:
-All scenes in hierarchy tab are saved
-All scenes are closed
-Zone_01 scene opens
-The sun (directional light) is added to Zone_01 scene
-Lightmaps are computed
-The sun (directional light) is delete in Zone_01 scene
-Zone_01 is saved

When starting the script:
if you do not want all the scenes in hierachy to 
be saved uncheck Scenes are Auto Saved 
checkbox

To easily reopen all scenes with a single click:
-press Open All Scenes button (spot 1)

-All scenes included in List of scenes opens
-The scene that contains Directional Light(sun) also opens

If you want one or more additional scenes to 
open as well:

-modify the scenes number (spot 2)
Increase the number increase the number of slots.
Lower the number reduce the number of slots.

-Write without error the name of the scenes into 
the field Other scenes (spot 3)

Important:
These scenes must be in the same folder (and therefore 
have the same path) as the scenes included in List of 
scenes (spot 4)



During the lightmap computed process:
-press Cancel button to cancel the lightmap 
calculation

To go further:
If you want to learn more about lightmaps as well as 

lightmap resolution settings: Link

Troubleshooting

Warning: Moving file failed

If this warning appears try these solutions:

-close Visual Studio (if it is open)
-before calculate lightmaps: save scenes 
manualy (Ctrl+S)

Issue: Grey bar stuck after the lightmap 
calculation is complete. (spot1)

-Click on grey bar (spot1)

A new window open : Not Responding (spot2)

-Press exit button (spot3) 

If you want to do another lightmaps calculation:
it is best to turn off Unity and then turn Unity back on.

If the problem persists:
-Try deleting the lightmaps folder before recalculating
-Try to restart your computer



7 Terrain, nature and trees

Overview

This chapter explain how to create your own map.

This chapter covers in detail how: 
-to create terrains
-setup terrains
-paint textures on terrains
-paint grass, bushes and stones

Terrain Tools 

First of all, if you haven't installed the Unity Terrain 
Tools package, we advise you to do so. 
This Unity package is free. 
It makes it easier and faster to work on terrain.
The explanations in this chapter will be made using 
this package.

Here is the process to install the package:

Go to Window > Package Manager

5 -Choose Unity Registry (spot 1)

-Choose Terrains_Tools (spot 2)

-Press Install button (spot 3)



Use Starter kit scene

All the elements to start a new map are included in the
starter kit. Starter kit use additives scenes setup.

Important:
This chapter does not explain the basics of using additive scenes. 

If you want to learn how to work with additives scenes read L  ink  

First, we will put in the hierarchy tab the 3 scenes of 
the starter kit:

1 In Project tab double click on SK_Gameplay_Scene 
to open it (spot 1)

 

Assets > HPA > Scenes > Starter_Kit > 
SK_Gameplay_Scene
 

SK_Gameplay_Scene is open (spot 2)

2 In project settings tab:
Select scene SK_Procedural
From project tab drag and drop SK_Procedural into 
the hierarchy tab

Assets > HPA > Scenes > Starter_Kit > SK_Procedural
 

3 In project settings tab:
Select scene SK_Zone_01
From project tab drag and drop SK_Zone_01 into the 
hierarchy tab

Assets > HPA > Scenes > Starter_Kit > SK_Zone_01

Now there are 3 scenes in hierarchy tab:  
SK_Gameplay_Scene , SK_Procedural and 
SK_Zone_01 scenes



SK_Gameplay_Scene included : (spot 1)

-scripts 
-character controller 
-sun light 
-clouds (skydome) 
-background mountains 
Important:
SK_Gameplay_Scene scene doesn’t requires lightmaps 
calculation

SK_Procedural : (spot 2)

This scene is used to add road, procedurally create 
fences and electricity pole.
This elements are create with a script included in the 
asset
To learn how to generate road, procedurally create fence and 

electricity pole with the script included in the asset read : L  ink  
Important:
Procedural scene requires lightmaps calculation.

SK_Zone_01 : (spot 3)

This scene is used to add terrain, building prefabs and
objects prefabs
Important:
SK_Zone_01 scene requires lightmaps calculation.

-In hierarchy tab select SK_Zone_01
-Mouse right click
-Choose Set Active scene

Important:
If SK_Zone_01 is set active, new terrain is created in 
SK_Zone_01 

Info:
When a scene is set active scene its name in the hierarchy 
tab is in bold



Add terrain neighborhood

In hierarchy tab: 
-select Terrain_Grp
SK_Zone_01 > Terrain_Grp 

On Terrain_Grp there is a script named 
Terrain_Starter.cs
This script allows to configure terrains in a few clicks.

This script allows to setup:
-terrains parameters
-terrains textures layers
-terrains mesh details (grass, plants and stones)
-terrains trees

In Hierarchy tab:
In SK_Zone_01 scene select Terrain (spot 1)

SK_Zone_01 > Terrain_Grp > Terrain

In Inspector tab:
Press Create Neighbor Terrains button (spot 2)

Important:
-Don’t forget  to set SK_Zone_01 Set Active Scene 
If you want to learn how to set active a scene read L  ink  

In Scene tab:
Click on the square to create a new terrain (spot 1)

A new Terrain is added (spot 1).



Create a new neighborhood terrain.

Create a new neighborhood terrain .

In hierarchy tab: 
-add the 3 news terrains into Terrain_Grp



Update list of terrains

In hierarchy tab: 
-Select Terrain_Grp

In Inspector tab: 
-Press Update the list of terrains

Very important:
Each time you add or remove terrain into Terrain_Grp 
you must press button Update the list of terrains

Setup terrain 

In hierarchy tab: 
-select Terrain_Grp

In Inspector tab:
-PressTerrain Settings button  (spot 1).

-Press Update Terrain Settings button (spot 2).

Parameters of the terrains are modified 

Important:
All the terrains that are in group Terrain_Grp will be modified by the
script



In hierarchy tab: 
-select Terrain_Grp

In Inspector tab:
-Press Terrain Layer button (spot 1).

-Press Update Terrain Layer button  (spot 2).

Layers Textures are added to all the terrains included into  
Terrain_Grp

In hierarchy tab: 
-select Terrain_Grp

In Inspector tab:
-Press Terrain Detail button (spot 1).

-Press Update Terrain Detail button  (spot 2).

Mesh Details (grass, plants and stones) are added to all the 
terrains included into Terrain_Grp



In hierarchy tab: 
-select Terrain_Grp

In Inspector tab:
-Press Terrain Tree button (spot 1).

-Press Update Terrain Tree button  (spot 2).

Tree (Bushes) are added to all the terrains included into 
Terrain_Grp

Terrain setup is Done

Terrain sculpting

T  o sculpt the terrain:  
-In hierachy tab select a terrain
-In Inspector tab select the second icon (spot 1).

-Click on the menu selection bar
-Choose Raise or Lower Terrain, Set Height or 
SmoothHeight



Learning how to use terrain sculpt tool is beyond the 
scope of this documentation but here some tips to help
you have good result.

Raise or Lower Terrain:

For small details use low Brush Strength value (for 
example 0.005)

SmoothHeight

To smooth harder increase the Blur Radius value (for 
example 10 or 20)
Work with large brush size

Paint terrain texture

T  o   paint     a   terrain:  
-In hierachy tab select a terrain

-In Inspector tab select the second icon (spot 1).

-Click on the menu selection bar
Choose Paint Texture (spot 2).

-Set Brush Strenght to 1 (spot 3).

-Set Brush Size to 10 (spot 4).

-Select a texture to paint (spot 5)



Custom brush

A custom brush is included in the asset.
This custom brush is designed to reduce texture tile 
effect.

In the picture on the right:

Texture tile is visible (spot 1).

Texture tile is less visible (spot 2).

To install the brush:

If Brush_M_01 is not automatically installed:

-Select a terrain
-In Inspector tab press New Brush button

-In Text Field type “brush” (spot 1).

-Double click on  Brush_M_01



A new brush is added in brushes Panel (spot 1).

Paint grass, plants and stones

To paint grass, plants and stones on terrains:

-In hierarchy tab select a terrain
-Press Paint Details button  (spot 1)

-Select a MeshDetail (spot 2)

-Adjust the settings as needed (spot 3)

-Start painting mesh details on terrain

Important:
Each MeshDetail cast shadows.
If you put too many mesh details on the map, it could 
cause performance drops.
Stones meshDetails doesn’t cast shadows.

Info:
It may happen that there is a bug displaying the icons, 
but this has no impact when painting the meshdetails 
in the scene.



Paint trees

To paint trees on terrains:

-In hierarchy tab select a terrain
-Press Paint Trees button (spot 1)

-Select Tree (spot 2)

-Set Brush size to 1
-Set Brush size to 10 (spot 3)

-Press Random checkbox to uncheck checkbox(spot 4)

-Press Random checkbox again
If random is on, each tree will be a slightly different size

-Pull the left end of the slider a little to the left (spot 5)

Important:
If you put too many trees on the map, it could cause 
performance drops



8 Prefabs

Prefabs Showroom

To discover all prefabs contained in this asset open scenes: 

Assets > HPA > Scenes >  Showroom  > Showroom_Prefabs_Objects
Assets > HPA > Scenes >  Showroom  > Showroom_Prefabs_Buildings

Prefabs folder

The buildings prefabs and objects prefabs are in the folder Prefabs

Assets > HPA > Prefabs 

Prefabs Tips

Unpack prefab

Prefabs unpack:
In hierarchy tab before Unity 2022.1  it is not 
possible to move elements into a prefab 
without having to unpack them first

But without breaking a prefab it is possible to:
- hide / unhide object included in the prefab
- move, rotate, scale an element included in 
the prefab

Info:
To keep a good optimization it is preferable 
not to unpack the prefabs (with the exception 
of building prefabs as explained later in this 
chapter)

In hierarchy tab in version 2022.1 + of Unity it 
is possible to move elements into a prefab 
without having to unpack them first

LODs

In the asset the prefabs that use LODs have 
the prefix "LOD_" at the beginning of their 
name.

Info:
LOD means “Level of Details”.
Prefabs with different levels of detail included in a LOD 
appear or disappear depending on the distance from the 
camera.



Flickering effects on some objects.

If objects flickering it’s probably because two 
similar objects exactly at the same position.
To solve the issue move one of the two 
objects a little bit.

Open / close all element in group in one 
click:

In hierarchy tab if you want to open all the 
elements included into a group in one click: 

In hierarchy tab :
Hold Shift(Maj) + Left Ctrl + Alt click on the 
triangle icon near the group (spot 1)

Do the same thing to close all the elements 
included into a group in one click.

Create group (script)

A script is included in the asset to easily 
create group:

To create a group:
-In hierarchy tab select more than one 
elements
(spot 1)
-Mouse Right click
-In the menu choose HP(spot 2)  then Create 
Group (spot 4)

If you want to create group and move to root 
of the scene choose  create Group + Move to 
Root (spot 5)

If you want to move select elements to root 
without making a group choose Move to Root 
(spot 3)

Important:
The other choice in list:
Optigrid Group and  Optigrid + Move to root are using for
optimization.

For learn more information about optimization read 
chapter Link



Snap Prefabs

To place certain prefabs very precisely it is 
interesting to use the snap system

In the asset the prefabs that use the snap 
have the prefix "SNAP_" at the beginning of 
their name.

Important:
To use Snap don't forget to setup Snap 
settings 
For more information about setup snap settings read: 
Link

Important:
When you move an object with "SNAP_" 
prefix be sure to select:
- Pivot mode 
- Global mode

Here the list of “SNAP” prefabs:

-Fences
Assets > HPA > Prefabs > Fence

-Walls
Assets > HPA > Prefabs > Walls 

-Bastion
Assets > HPA > Prefabs > Bastion

-Metal stairs and walls
Assets > HPA > Prefabs > Stairs > Stairs_Metal > 
Metal_Floor

Snap Tutorial

1 In Project tab double click on Tuto_Snap to 
open it (spot 1)

 

Assets > HPA > Scenes > Tuto > Tuto_Snap

2 From project tab drag and drop 
LOD_SNAP_Wall_Brick_01 in the hierarchy 
tab 

 Assets > HPA > Prefabs > Walls >Wall_Brick > 
Large > LOD_SNAP_Wall_Brick_01



3 In hierarchy tab:
-Select LOD_SNAP_Wall_Brick_01 
-Ctrl + D to duplicate

5 In scene view:

-Press W to activate Move tool
-While holding down  the CTRL key pressed 
move LOD_SNAP_Wall_Brick_01  on Z axis 
twice.

Important:
When an object is moved while holding down 
the Ctrl key  the snapping mode is used

The position of LOD_SNAP_Wall_Brick_01 (1) 
must be
X: 0 
Y: 0
Z: -3

Procedural objects

Roads, utility poles and some fences are not 
prefabs
This elements are created with a script 
incuded in the asset.

To learn how to generate road, fence and electricity pole 
Li  nk  



Colliders

In some cases, it may be better to remove the 
colliders of certain objects and replace them 
with another collider.
For example of the case of a pile of objects 
fallen on the ground.

The special colliders can be found in the 
following folder:

Assets > HPA > Prefabs > Collider

To make the collider active but invisible:
-Uncheck MeshRenderer checkbox

Prefabs in details

Doors and  Furnitures Drawers

In the hierarchy tab:
-to open or close the drawer of furniture use 
the MOVE group (spot 1)

-to open or close a cabinet door use the 
PIVOT group (spot 2)

-to open or close a door use the PIVOT group 
(spot 2)



Important: 
Before rotate PIVOT group don’t forget to 
choose Pivot Mode

Important: 
Drawers and doors are not included in 
lighmaps. 
Contribute GI is not check (spot 1)

Drawers and doors use lightprobs.
For more informations about lightprobs read L  ink  

Buildings

If you are using unity 2021 version it's best to 
unpack building prefabs so you can easily 
move or delete objects into the building
To unpack a prefab:

-In hierarchy tab select a building prefab (spot 
1)

-Mouse Right Click
-Prefab > Unpack (spot 2)

Are included in  to   the buildings:  

-Buildings floor, walls and roofs prefabs

-One or more reflections probs
For more informations about reflection Probs read L  ink  



-LightProbs
For more informations about Lights Probs read L  ink  

-EyeAdaptation (Local Post Fx):
EyeAdaptation simulates the adaptation of the
pupil when entering or leaving a building. It's a
local Post FX.
For more informations about local Post FX read   L  ink  

Important:

In building prefabs Eye Adaptation system is 
disabled.
To use Eye adaptation:
In building prefabs unhide Grp_EyeAdaptation

-Lights
For more informations about lights read L  ink  

-Group named HIDE.
Through a script this objects included into the 
group are hide or unhide depending on the 
distance of the camera.
This optimization script is included in the asset
For more informations about optimization script read 

L  ink  

Important:
There are two versions of building prefabs:
-The first version: with optimisation scripts 
If you want to use the optimization script, use 
these prefabs.
HPA > Prefabs > Buildings > With_Optimisation 

-The second version: without optimisation 
scripts
If you don't want to use the optimization script,
use these prefabs
HPA > Prefabs > Buildings > Without_Optimisation 

Particles

The particles prefabs are in folder Particles

Assets > HPA > Prefabs  > Particles

Through a script particles are hide or unhide 
depending on the player distance .
For more informations about optimization script read 

L  ink  



Environment

Prefabs Included in folder Environment are 
designed to recreate far away elements like 
clouds, and mountain.

Assets > HPA > Prefabs  > Environment

These elements are ready to use in the starter
kit
For more informations about the starter kit read L  ink  

Pipe

The pipe prefabs are in folder Pipe

Assets > HPA > Prefabs  > Pipe

In prefabs folder pipes are only available in 
one color. This is to avoid too many prefabs.
If you want another color of pipes:
-In project bar open folder _Drag_n_Drop

Assets > HPA > Materials  > _Drag_n_Drop > Pipe

-From project tab drag and drop material to 
the pipe in scene tab.



9 Roads, electricity Pole and procedural fence

Overview

A script allowing to create procedural elements is 
included in the asset

Script allows to create:
-Roads on terrain
-Electricity pole with procedural wires
-Procedural fences
-Crash Barrier

Infos:
Objects created with the script are not prefabs. Added this 
objects increase the size of scenes more than prefabs.
It is better not to copy/paste these objects.

Setup

Go to Tools > HP > Generator > Window Panel

-Click on circle icon (spot 1)

-Choose Rdata (spot 2)

Info:
This setup should only be done the first time the panel is opened

In scene view: 
-click on gizmos icon to activate gizmos



Create roads

In Project tab double click on Tuto_Procedural scene 
to open it.
 

Assets > HPA > Scenes > Tuto > Tuto_Procedural 

Into the procedural panel:

-Click on select bar (spot 1)

-Choose Road Asphalt Large (spot 2)

-Press Add to the scene



In hierarchy tab:
A new road is created.

-Select the new road

-Position the mouse over the terrain where you want 
to start the road

Into scene view:
Mouse right click to activate scene view
Do this only the first time you create a point n

-Press keyboard shortcut N

The first point is created

Important:
If the first point doesn’t appear:

-Verify that gizmos are activate in scene tab
-In scene view select the terrain
-In hierarchy tab select again the new Road
-Press keyboard shortcut N



-Position the mouse over the terrain where you want 
to create the second point.

Don’t forget:

To create a point, the road must be selected in the 
hierarchy tab.

-Press keyboard shortcut N
The second point is created

Info: 
if you want to undo:
-Press keyboard shortcut Ctrl+Z

Info:
During roads creation you may have this following 
warning:
Cross scene references are not supported

Do not take this warning into account.

-Position the mouse over the terrain where you want 
to create the third point.

-Press keyboard shortcut N
The third point is created

-In hierarchy tab unselect Road Asphalt Large

Road points are no longer selectable



-In hierarchy tab select Road Asphalt Large (spot 1)

Road points are selectable (spot 2)

-Click on the second point to select it

Point turns green

-Hold Shift (Maj)
X Y Z translation handles appear



While holding down the Shift (Maj) move handle on Y
axis.

-Press U to update the Road

-In Inspector tab
Press Road Selection button (spot 1)

Press Select All button (spot 2)

Green lines appear on the sides of the road (spot 3)

-In Inspector tab
Press Update Terrain Height button (spot 1)

The terrain has adapted to the shape of the road 
(spot 2)



-In Inspector tab
In Border size section: (spot 1)

set Left slope to 1
set Left to 1
set Right to 1
set Right Slope to 1

In Selection section: (spot 2)

set Max to 40 so that only half of the road will be 
affected

-In Inspector tab
Press Update Terrain Height button (spot 1)

Transition between terrain and road is smoother but only at the 
beginning of the road (spot 2)

-In Selection section: 
Press Select All button (spot 1)

-In Inspector tab
Press Update Terrain Height button (spot 2)

Transition between terrain and road is smoother all along the 
road 

To select several points at the same time

-Select a Point (spot 1)

Point turns green

-While holding down the Left Ctrl select a second 
point
Second point turns blue (spot 2)



-Press C to split

A new point is created between the 2 points (spot 1)

-Select the new point.
-Press G to delete the point

Important: 
Don’t forget to press U when you want to update the shape of the
road

Create crossroad

-In Inspector tab
Press Road Crossing button (spot 1)

-Choose End (spot 2)

The type of road is automatically configured to match the road 
type (spot 3)

Info:
the dot that indicates the start of the road is bigger 
than the dot that indicates the end of the road



-In Inspector tab
Press Create button (spot 1)

A new crossroad is created (spot 1)

-Press Road From Start to End button to adapt the 
terrain to the new crossroad (spot 2)

-In hierarchy tab select the crossroad (spot 1)

A different color indicates each side of the crossroads
(spot 2)

-Press Create new road section in front of the green 
square (spot 3)

A new road is created from the crossroads 



Road terrain texture

As the camera move away the definition of the terrain
decreases. The terrain no longer fits perfectly with 
the road. To solve this problem we will paint texture 
on the ground under the road.

In hierarchy tab :
Select Terrain (spot 1)

In Inspector tab:
-Press button Paint Texture (spot 2)

-Choose Paint Texture  (spot 3)

-Set Brush Strenght to 1
-Set Brush Brush Size to 17 (spot 4)

-Select 08_Asphalt_Road texture  (spot 5)

Paint the asphalt texture under the road



Now even when the camera moves away, the road 
remains visible.

Info:
If you create a pathway with the preset road sand 
path:
-use the terrain texture 01_Sand_Gravel, 
06_Sand_01 or/and   07_Sand_02 to paint the terrain

Road colliders

To adapt the terrain to the road, colliders are created.
Once the road is adapted to the terrain these 
colliders are no longer useful.
It is necessary to delete them.
If you do not remove them, it is possible to have 
invisible collisions at certain places of the terrain

Go to Tools > HP > Generator > Delete Road 
Colliders

All the roads colliders are remove.

Important:
If you modify the roads again, new colliders will be 
created.
Don't forget to delete them.



Modify the curve of a road

In Project tab double click on Tuto_Procedural_02 
scene to open it.
 

Assets > HPA > Scenes > Tuto > Tuto_Procedural_02 

Very Important:

Don’t select the road into the hierarchy tab.
This can cause problems when trying to access the 
curve handles
Select the road into the scene tab.

-In the scene tab select Road Asphalt Large_1018

-Select the point of the road as indicated on the 
image on the right

Point turns green

-While holding down the Shift (Maj)  press S then 
release S

New handle appears



-While continuing to hold down the Shift (Maj), move 
red axis as indicated on the image on the right

-Press U to update the Road

You have learned the main techniques for creating roads.

To finish as a reminder
Here is the list of keyboard shortcuts:

Split curve: select 2 points then press C 

Delete Point: select point then press G

Active Handle: While holding down the Shift (Maj)  
press S then release S
While continuing to hold down the Shift (Maj), move 
the axis you want.

T  o select several points  
-Select a Point 
-While holding down the Left Ctrl select a second 
point



Advanced Techniques

In this part we will see advanced techniques for 
editing routes.

Create a crossroad from a point 

In Project tab double click on Tuto_Procedural_03 
scene to open it.
 

Assets > HPA > Scenes > Tuto > Tuto_Procedural_03

-In the scene tab:
 select Road Asphalt Large_1018

-Select the point in the middle of the road curve (spot 
1)
Point turns green

-In Inspector tab:
Press Road Crossing button (spot 2)

-In Inspector tab:
Press Split And create road crossing button (spot 3)

A new crossroad is created

Connect a road with a crossroad

In Project tab double click on Tuto_Procedural_04 
scene to open it.
 

Assets > HPA > Scenes > Tuto > Tuto_Procedural_04
 

-In hierarchy tab select Road Asphalt Large_1018 
(spot 1)

-In Inspector tab:
Press Road Crossing button (spot 2)

Press Connect button (spot 3)

Choose End button (spot 4)

Press Cross Road List button (spot 5)



-In Inspector tab:
Choose Cross 1015 (spot 1)

Choose Yellow Dot (spot 2)

Press Connect button (spot 3)

Road is now connected with crossroad

Align points on curves

In Project tab double click on Tuto_Procedural_03 
scene to open it.
 

Assets > HPA > Scenes > Tuto > Tuto_Procedural_03

-In hierarchy select Road Asphalt Large_1018

In scene tab:
-Select the first point of a curve (spot 1)

-While holding down the Left Ctrl select the other 
points (spot 2)



In Inspector tab
Press Point Manipulation button (spot 1)

-Press Z button to align points on Z axis (spot 2)

-Press U to update the Road

Create fences

First if you have not setup the procedural script read 
this part Link

In Project tab double click on Tuto_Procedural_05 
scene to open it.
 

Assets > HPA > Scenes > Tuto > Tuto_Procedural_05

Important:
Don't forget to enable gizmos in scene mode if you 
don't.

Go to Tools > HP > Generator > Window Panel



-In select List Choose Fences (spot 1)

Note:
Fences_Warehouses works the same way as Fences

-Press Add to the scene button (spot 2)

The curve system for creating fences is the same 
curve system for creating roads.

For more informations about how to create roads L  ink  

You can use the same keyboard shortcuts:

Split curve: select 2 points then press C 

Delete Point: select point then press G

Active Handle: While holding down the Shift (Maj)  
press S then release S
While continuing to hold down the Shift (Maj), move 
the axis you want.

T  o select several points  
-Select a Point 
-While holding down the Left Ctrl select a second 

In hierarchy tab :
Select Fence (spot 1)

-Into scene view:
 Mouse right click to activate scene view
Do this only the first time you create a point

In scene tab:
-Press keyboard shortcut N to create points (spot 2)

Important:
If the first point doesn’t appear:

-Verify that gizmos are activate in scene tab
-In scene view select the terrain
-In hierarchy tab select again the new fence



-Press keyboard shortcut N

In Inspector tab :
Press Instantiate Objects button (spot 1)

Fences are created (spot 2)

In hierarchy tab a new game objets is added to fence group (spot
3)

Important:
If you want to change the fences creation settings:

-In hierarchy tab :
Select Fence (spot 1)

-In Inspector tab
Check Advance Checkbox  (spot 2)

-Set Parameters according to your needs  (spot 3)

In hierarchy tab :
In Fence:
Select one of the new game object (spot 1)

In hierarchy tab :
In Fence:
Delete the game object

The wires are no longer correctly connected to the posts of the 
fence



-In hierarchy tab :
Select New Game Object (spot 1)

-In Inspector tab :
Press Update Group button (spot 2)

The wires are again connected to the posts of the fence (spot 3)

Create crash barrier

First if you have not setup the procedural script read 
this part Link

In Project tab double click on Tuto_Procedural_05 
scene to open it.
 

Assets > HPA > Scenes > Tuto > Tuto_Procedural_05 

The curve system for creating crash barrier is the 
same curve system for creating roads and fences 

For more informations about how to create roads L  ink  

You can use the same keyboard shortcuts:

Split curve: select 2 points then press C 

Delete Point: select point then press G

Active Handle: While holding down the Shift (Maj)  
press S then release S
While continuing to hold down the Shift (Maj), move 
the axis you want.

T  o select several points  
-Select a Point 
-While holding down the Left Ctrl select a second 
point

Important:
Don't forget to enable gizmos in scene mode if you 
don't.



Go to Tools > HP > Generator > Window Panel

-In select list choose CrashBarrier_Metal (spot 1)

-Press Add to the scene button (spot 2)

In hierarchy tab :
Select CrashBarrier_Metal (spot 1)

-Into scene view:
 Mouse right click to activate scene view
Do this only the first time you create a point

In scene tab:
-Press keyboard shortcut N to create points (spot 2)

Important:
If the first point doesn’t appear:

-Verify that gizmos are activate in scene tab
-In scene view select the terrain
-In hierarchy tab select again the new crash barrier
-Press keyboard shortcut N

In Inspector tab :
Press Generate Mesh button (spot 1)

Barrier is created

In Inspector tab :
Press Instantiate Objects button (spot 1)

Plots are created (spot 2)



To delete a pole

In hierarchy tab:
Into New Game Object group (spot 1):

-select a pole (spot 2) 

-delete it

To reverse Crash barrier

In hierarchy tab :
Select CrashBarrier_Metal 

In Inspector tab press Mirror Button (spot 1)

 

A new window appears

Press Continue button 

In Inspector tab :
Press Generate Mesh button to mirror the barrier 
(spot 1) 

Press Instantiate Objects button to mirror the plots 
(spot 2) 

Create High Voltage Pole

Procedural utility poles do not work the same as 
roads, fences, and crashbarrier

In Project tab double click on Tuto_Procedural_05 
scene to open it.
 

Assets > HPA > Scenes > Tuto > Tuto_Procedural_05 



-From Project tab drag and drop 
Electricity_HighVoltage_Manual into the scene tab

Assets > HPA > Prefabs > Electricity> Procedural >  
Electricity_HighVoltage_Manual

-In hierarchy tab 
select Electricity_HighVoltage_Manual (spot 1)

In Inspector tab :
Press Update List +Update Wires (spot 2)

Wires are created (spot 3)

-In hierarchy tab 
select 200 

 -Ctrl + D to duplicate 200

A new plot named 200(1) is created

Select 200(1)
Move  200(1) as indicated on the image on the right

-In hierarchy tab 
select Electricity_HighVoltage_Manual (spot 1)

Press Update List +Update Wires (spot 2)

Wires are updated (spot 3)



Create Electricity Utility Pole

If you want to create Electricity_UtilityPole

-From Project tab drag and drop 
Electricity_UtilityPole_Manual into the scene tab

Assets > HPA > Prefabs > Electricity> Procedural > 
Electricity_UtilityPole_Manual

Electricity UtilityPole and  Electricity HighVoltage
works the same way



10 Lightings

Overview

This chapter explains how to configure the lighting to 
have the same rendering as in the demo.
Of course you can create your own lighting setup or 
adapt these tips according to the needs of your 
project.

Sun, Aera lights and spots lights

3 types of light are used in the project.

-Sun: 
Directional light set to mixed mode
Mixed mode means:
Lightmaps are baked and must be precomputed.
Shadows are in realtime. It is therefore possible to 
modify the direction of the sun in realtime

Sun is ready to use in the starter kit

-Aera lights:
These lights are used to increase the intensity of light 
into the buildings.
These lights are baked only.

Aera Lights are ready to use into buildings prefabs.
You can adapt the lights according to the needs of your project.

-Spot light or point light
These light simulate light sources such as a lamp, 
neon, fire etc.
These lights are realtime only.
It is possible to move them in realtime.

These lights are in the folder:
Assets > HPA > Prefabs > Lights

Important:
Realtime spot lights and point lights are resource 
intensive.

This is why a script is added which allows to activate 
or deactivate the shadow of the light according to the 
distance with the camera.
This script is included in the asset.

For more informations about light optimization read L  ink  



Reflection Probs

-A reflection probe must encompass the entire scene
Global reflection prob is ready to use in the starter kit

-Each building has one or more reflection prob so that 
the reflections inside the building are correct
Reflection probs are ready to use in the prefabs buildings

Tips:
If a building lighting doesn't look right, reflections look weird, or the
building doesn't look well integrated with the terrain:
-Check if the reflection prob encompasses the whole building
-Check that the center of the reflection prob is inside the building

Lightmaps

Overview:
The asset is designed for use with additive scenes .
Use additively load scenes allows to not recalculate 
the lighmaps for the whole scene. It's faster and it 
avoids problems during lightmap computation on less 
powerful PC.

When using additive scenes, you have to calculate the
lightmaps for each scene separately. 
The lightmaps are recombined automaticaly 
afterwards when all the scenes are put into the 
hierarchy tab.

A script is included in the asset to easily calculate 
lightmaps with additives scenes.
If you want to learn how to use lightmaps script : L  ink  

Calculating lightmaps without the script can be 
tedious, which is why it is better to use the script.

Lightings Presets:

Ready to use lighting presets are included in the 
asset.

-Go to Window > Rendering > Lighting



-Click on circle icon (spot 1)

-Into the list choose Lighting_Presets (spot 2) 

Assets > HPA > Lightings > Lightings_Settings>  
Lighting_Presets

Demo scene is very large then a low Lightmap Resolution is
used (spot 1)

Increase the Lightmap resolution value increase the quality 
of the lightmaps but:
-Lightmaps computation is longer
-Lightmaps size are bigger 

The size of the lightmaps are visible at the bottom of the lighting 
tab (spot 2)

In Lighting tab Lightmap Resolution parameter is set to 2.

A value of 2 is good for elements that are outside of 
buildings. 
On the other hand, for buildings and objects inside 
buildings, this definition of lightmaps is not sufficient. 

It is therefore necessary to increase the definition of 
lightmaps, but only for buildings. 

To increase the quality of lightmaps of a particular object, 
you must increase its scaleInLighmap parameter. 
Changing the scaleInLightmap value of each object would 
be very tedious. 
This is why a script is included in the asset, to modify the 
scaleInLightmap parameter of a set of objects with one 
click. 

To learn how to use the script: Link

Important:
In demo scene: 
Folders named Scale_x4 contains objects with a scaleinLightmap 
value of 4 



Lightmap calculation time 

Info:
Do not rely on the time indicated at the beginning of 
the calculation of the Lightmaps. The calculation time 
is much shorter than the times indicated at the 
beginning of the calculation.

PC configuration   for test  :   
Intel(R) Core(TM) i7-9700K CPU @ 3.60GHz 
RAM 16,00 Go
Nvidia Geforce GTX 1060 6GB

Here is the calculation time of demo scenes:
The calculation time is about 2 to 5 minutes per zone 
(Zone_01 to Zone_09)
The calculation time is about 1 minute for Procedural 
scene
Gameplay_Scene consists of gameplay elements and 
scripts. It should not be calculated.

Tips to reduce rendering time

-In Lighting tab uncheck Progressive Update checkbox

Window > Rendering > Lighting



LightProbs 

LightsProbs are using to light objects which are not 
static like character, doors, furnitures.

Contribute GI is uncheck for this objects

The lightsprobes are not very useful outside the 
buildings because the light is globally homogeneous 
(except for night scenes if there are light sources)
On the other hand, lightprobs are very useful in 
interiors because the variations in light intensity are 
stronger (whether or not you are next to windows)

Note:
In buildings prefabs, lightprobes are included but will need 
to be adjusted according to your needs

Very Important:
When working with additive scenes you need at least 
one lightprob per scene with the exception of the 
scene including the gameplay elements 
(Gameplay_Scene)

To create a lightprob:
GameObject > Light > Light Probe Group



Combine lightprobes when working with additives 
scenes

When using additive scenes, Lightprobs of the 
differents scenes are not automatically combine.
It is necessary to add a script to combine the 
lightsprobs of the different scenes

code:
  void OnTetrahedralization(){
            isTetraDone = true;
            }

This script is attach to prefab: Init_LightProbes 

Assets > HPA > Scripts >  Additives_Scenes > Lightprobes 
> Init_LightProbes

Add the prefabs into your Gameplay scene 

In demo Init_LightProbes script is added to 
Gameplay_Scene and ready to use.
In Starter Kit this script is added to SK_Gameplay_Scene 
and ready to use

Update tetrahedral tessellation into the Editor

Into the editor, if the lightprobs do not refresh 
automatically in the scene tab:

-Go Tools > HP > Tetrahedron Refresh



Scale in lightmap script

This script is designed to increase scaleInLightmap 
parameter of a group of objects in one click.
This script is  useful to increase scaleInLightmap value
of LOD_Prefabs.
Increasing scaleInLightmap improves the quality of 
lightmaps only for one object and not for the whole 
scene.

1 In Project tab double click on Tuto_ScaleInLighmap 
scene to open it 
 

Assets > HPA > Scenes > Tuto > Tuto_ScaleInLightmap

2 In Hierarchy tab select Oil_Tank_02_Lod0  (spot 1)

ScaleInLightmap is set to 1 (spot 2)

3 In Hierarchy tab select Oil_Tank_02_Lod1  (spot 1)

ScaleInLightmap is set to 0.5 (spot 2)

4 Go to Tools > HP > Lightmap Size Modifier

A new window appear

5 In Hierarchy tab select Grp_Tuto (spot 1)

6 In window press Update Lightmap Multiple button 
(spot 2)



A new window appear

7 In window press Continue button

In group Grp_Tuto scaleInLightmap of all objects has 
been multiplied by 2

Important:
In the hierarchy tab select only one group.
If you select several groups at the same time, only the 
last one will be taken into account

8 To revert to default scaleInLighmaps value 

-In Hierarchy tab select Grp_Tuto
-In Window press Revert prefabs ScaleInLightmaps 
button

In a Prefabs that has an LOD component: 

ScaleInLightmap value:
lod0 = 1 
lod1 = 0.5 
lod2 = 0.25 
lod3 = 0.125

If you choose to multiply by 4:
ScaleInLightmap value:
lod0: 1 x 4 = 4 
lod1: 0.5 x 4 = 2 
lod2: 0.25 x 4 = 1 
lod3: 0.125 x 4 = 0.5

Important:
Increasing scaleInLightmap value increase the render 
time of the lightmaps and the size of the lightmaps



11 Post Fx

Lightings and environments parameters

Important:
When working with additive scene:
To avoid any problems, it is best to use the same 
environment presets.

When using the additive scene system, the active 
parameters are those of the scene which is "active 
scene"

SetUp

PostFx must be enabled. If you haven't done it yet:
In Project settings tab:

-Select UniversalRenderPipelineAsset_Renderer (spot 
1)
 
Assets > HPA >  RenderPipeline

-Check Enabled Checkbox  (spot 2)

Global PostFx

To add global Post Fx to the scene :
-From Project tab drag and drop Post_Effects prefab 
to hierarchy tab

Assets > HPA >  Post_Effects > Global > Post_FX

Global post FX is ready to use in the starter kit and demo scene

Local PostFx

EyeAdaptation simulates the adaptation of the pupil 
when entering or leaving a building. It's a local 
PostFX.

In scene view: 
-click on gizmos icon to activate gizmos 



How It works:
In the picture on the right:

-Orange square that represents the floor of the house
-House door number 1 (spot 1)

-House door number 2 (spot 2)

-PostFx Gizmo box (spot 3)

If the player enters through a door (door 1 or 2), the 
postFx is triggered.
When the player leaves the house through a door 
(door 1 or 2)  postFx stops.

A trigger must be placed at each entrance/exit of the 
building.

In prefab Grp_EyeAdaptation doors trigger are 
Trigger_01 and Trigger_02  (spot 1)

Scale and move trigger according to your needs 
If you need more entry duplicate Trigger_01 or  
Trigger_02

In your project if the player respawn into the building:
Put TriggerInsideOnly at player respawn point (spot 2)

Important:

Grp_EyeAdaptation is included in all buildings prefabs
and ready to use.

But in building Eye Adaptation prefabs system is 
disabled.
To use Eye adaptation:
In building prefabs unhide Grp_EyeAdaptation

You will find Grp_EyeAdaptation prefab in the folder:
Assets > HPA >  Post_Effects > Local > 
Grp_EyeAdaptation



Info: 
If you don’t want to use Eye Adaptation system:
delete Grp_EyeAdaptation group

Lens Flare

There is a lens flare component on SUN Light.
If you don’t want to use :

-Select Sun directional light:
-In Inspector tab uncheck Lens Flare (SRP) 
checkbox.

Fog

To setup fog:

-Go to Window > Rendering > Lighting
-Choose Environment tab (spot 1)

-Set  Density to 0.0012  (spot 2)

-Set  Mode to Exponential Squared
-Set  Color to B9D0E2



12 Optimization

Overview

Large environment needs optimization.
This is why optimization scripts are included in the 
asset.

Optimization system

Overview:
A script is included in the asset that makes some of 
the objects hide or unhide depending on the 
distance from the player position.

For whatever reason if you don’t want to use optimization 

script read: L  ink  

The script is separated in  2 cases. 
Depending on the position and size of objects, case 
1 or case 2 will be chosen.
The two cases are used together.

Case 1 : grid system 
Objects appear or disappear depending on the 
player position on the grid.
This system is ideal for small to medium sized 
objects that are not inside buildings.

For large objects use case 2 instead.

Case 2 : group distance system
A distance is assigned to a group (for example 500 
meters)
Objects included in this group will be visible within 
500 meters.
This case is ideal for objects that are in buildings 
and large objects outside buildings.
Each group can have a different distance setup.

Small objects must be visible at 50 or 100 meters . 
Medium or large objects must be visible at 300 or 
400 meters.



Very Important:

To determine the distance, the optimization system 
takes into account the center of the group

In image 1:
The center of the group is in the middle of the 
objects.
This position is correct

In image   2  :  
The center of the group is not in the middle of the 
objects.
This position is incorrect

If the center of the group is not correctly placed it is 
possible that certain objects:
-do not appear
-appear/disappear at the wrong time

Important:
To work, the system must know the position of the 
character controller of the player.

For more information about how to connect optimize 

script and character controller: Link
Demo character included in the asset is already setup.



Case 1: Grid

1 In Project tab double click on Tuto_Optimize scene
to open it 
 

Assets > HPA > Scenes > Tuto > Tuto_Optimize

2 Click on Gizmo icon to activate gizmos visibility
 (spot 1)

In the Scene tab you can see a dot grid.

If you don’t see dot grid:

In hierarchy tab select GridOptimization

Hierarchy Tab:  Manager > Grid Optimization



Check Show Gizmo checkbox

In hierarchy tab:
-select GridOptimization (spot 1)

Hierarchy Tab:  Manager > Grid Optimization

In scene tab size of terrain is 900 x 600 (spot 2)

size of terrains = (3 terrains x 300m) x (2 terrains x 300m)

In Inspector tab :
-set Terrain X to 600  
-set Terrain Y to 900  (spot 3)

-set Row to 5  
-set Column to 5  (spot 4)



How it works

The player is in yellow area.
Blue aera consists of the 9 zones around the yellow 
zone.
Objects that are in blue area are activated
Objects that are not in this area are deactivated

Set row and column according to your needs

Important:
For the script to work, the objects must be in a group
that has the script TSStreamGridTag

Add   TSStreamGridTag    script to group:  

In hierarchy tab:
-select:
LOD_Tire_Pile_02  
LOD_Construction_Dumpster_01 
LOD_Pallet_Pile_03
LOD_Tire_Pile_03



-Right mouse click
-In the menu choose HP > OptiGridGroup

A new group is created.
Script TSStreamGridTag is added to the group

In hierarchy tab:
-select Grp_Opti  (spot 1)

Script TSStreamGridTag is added to the group
(spot 2) 

Now this group works with the grid optimization system

There is another way to add the script to a group:

-In hierachy tab select a group (spot 1)

-Press Add component button  (spot 2) 



-In search field type TS (spot 1)

-Choose TS Stream Grid Tag (spot 2)

Optimization grid fine tuning 

In hierarchy tab:
-select GridOptimization (spot 1)

Manager  > GridOptimization

Important:
OptiGrid group activated or deactivated ten objects 
by frame.This avoids framerate drops.

-If you want to activated more or less objects by 
frame set How Many Objects Update By Frame 
value (spot 2)

-If you want to hide Grid gizmo unckeck Show 
Gizmo checkbox (spot 3)



Important:
Each element included in Grp_Opti is considered as 
one object (spot 1)

If a grp containing many objects is included into 
Grp_Opti, it will be considered as one object (spot 2)

For good optimization:
In the Grp_Opti avoid putting groups containing too 
many objects.

This also applies to distance groups (case 2)

Case 2: Group Distance

-In hierachy tab:
 create an new empty (spot 1)

-Rename it HIDE for example (spot 1)

-In Inspector tab press Add component button (spot 2)

-In search field type TS (spot 1)

-Choose TSStreamDistanceTag (spot 2)

-Add LOD_Chair_06 to HIDE Group 

-Set transform position of  LOD_Chair_06  to  
X =0
Y= 0

Z= 0   

LOD_Chair_06 is now at the center of  HIDE Group 



Reminder:

To determine the distance, the optimization system 
takes into account the center of the group

-Select HIDE Group (spot 1)

-Set Distance Min to 200 (spot 2)

When the player is within 200 meters of center of 
HIDE group objects are activated.
When the player is more than 200 meters of the 
center of HIDE group, objects are deactivated.

Test Interval: 

The script tests the distance between the player and 
the group at regular intervals.
Depending on the player's movement speed, it is 
necessary to adjust the interval.

If the parameter is badly adjusted, the objects will 
appear too late (clipping) or too early (bad 
optimization)

To adjust the interval set Ref Distance Per second 
parameter as needed
Tips: If you find that objects appear too late (clipping) 
increase the value

Info:
In the demo scene:
OptiGrid (case1) and distance HIDE group (case 2) are 
already setup.

Into project folder:
There are two versions of building prefabs (Houses, 
Shops, Warehouses…).

-The first version: with optimization scripts 
If you want to use the optimization script, use these 
prefabs.
HPA > Prefabs > Buildings > With_Optimisation 

-The second version: without optimization scripts
If you don't want to use the optimization script, use these 
prefabs
HPA > Prefabs > Buildings > Without_Optimization 



Lights optimization

Realtime point Lights and spots lights are resource 
intensive.
For more informations about realtime spot lights and point lights 

read link

A script to optimize realtime point lights and spots 
lights is included in the asset.

How it works:

Light is activated or deactivated regarding the player
distance from the light source.
Light intensity increases with a smooth transition.
The shadow of the light is activated or deactivated 
regarding the player distance from the light source.
The shadow  intensity increases with a smooth 
transition.

1 The camera is more than 30 meters away from the
light.
Light is deactivated

2 The camera is 30 meters from the light
Light is activated. Light Intensity =0.

3 The camera is 25 meters from the light
Light intensity increase.
Shadow is activated. Shadow Intensity =0.

4 The camera is 20 meters from the light
Light reach maximum intensity.
Shadow intensity increase.

5 The camera is 10 meters from the light
Shadow reach maximum intensity

To modify the distances according to your needs:

In project tab:
-select Point_Light to view the script in the Inspector 
tab.

Assets > HPA > Prefabs > Lights > Point_Light

-Enabe Light : Light activation distance (spot 1)



-Reach Max Intensity :  Distance at which the 
intensity of the light is at its maximum (spot 2)

-Enable Shadow : Shadow activation distance (spot 3)

-Reach Max Strength: Distance at which the shadow
intensity is at its maximum (spot 4)

Important:
Shadow is activate at runtime by the script. In 
hierarchy tab, if you activate shadow for working:
-before play the game, deactivate the shadow   

Important:

To activate the lights when the scene starts, you 
must put the script Light_Manager into the gameplay
scene (in demo project the scene named 
Gameplay_Scene)

Assets > HPA > Prefabs > Lights > Light_Manager

Info: Light_Manager script is already included in the 
demo scene and the starter kit



Grid optimization (coding)

If you want initialize manually the OptimizationGrid 
system   from any script   call  :
HP.Generics.TSOptiGrid.instance.Init();

To update manually the OptimizationGrid System, 
from any script : call these 2 lines inside a coroutine:

(It is useful if you want to create a spawn system for 
example)

// Call the method to update the Optimization 
grid

yield return new WaitUntil(() => 
HP.Generics.TSOptiGrid.instance.ForceOptimizatio
nGridUpdate());

// Wait until all the objects on grid are updated

yield return new WaitUntil(() => 
HP.Generics.TSOptiGrid.instance.objsDistanceList
.Count == 0);

Disable ou delete Optimization 

Overview 

This chapter explains how to disable or remove the 
optimization scripts included in the asset

Disable Optimization grid

If you don’t want to use optimization grid script follow
this step:

1 In the starter kit:
In Project tab double click on SK_Gameplay_Scene 
to open it (spot 1)

 

Assets > HPA > Scenes > Starter_Kit > 
SK_Gameplay_Scene
 

 In the demo scene:
In Project tab double click on Gameplay_Scene to 
open it (spot 1)

 

Assets > HPA > Demo > Gameplay_Scene



2 In hierarchy tab:
In Manager group: 
-select GridOptimization (spot 1)

3 Unckeck Is Initialized When Scene Start checkbox 
(spot 2)

Remove Optimization grid

In hierarchy tab:
delete GridOptimization

Delete Opti grid script on objects (case 1)

-In search text field type Grp_Opti (spot 1)

-In Hierarchy tab select all the Grp_Opti (spot 2)

-Mouse right click on TSStreamGridTag name (spot 3)

-Choose Remove component

Delete Distance Group script on objects (case 2) 

-In search text field type HIDE_ (spot 1)

-In Hierarchy tab select all the HIDE_ (spot 2)

-Mouse right click on TS Stream Distance Tag name 
(spot 3)

-Choose Remove component



Colliders and optimization scripts

The objects included in the optimization are disabled
in the distance.

This means that the colliders included in these 
objects are disabled too. For example if these 
colliders are used for ground on which an enemy is 
moving, the collider must not be disabled.

In this case move the colliders outside of these 
group.

SSAO (Screen Space Ambiant Occlusion)

SSAO uses a lot of resources so you can disable it if
you wish.

To deactivate it:
In project tab select: Universal Render Pipeline 
Asset_Renderer (spot 1)

In Inspector tab uncheck Screen Space Ambiant 
Occlusion checkbox (spot 2)



13 Combine additive scene into one scene

The asset is designed for use with additive scenes.
For whatever reason if you don’t want to work with scenes additive and want to combine the 
demo scenes into a single scene follow this tutorial:

1 In Project tab double click on Combine scene 
to open it 
 

Assets > HPA > Scenes > Combine > Combine

2 From Project tab drag and drop this scenes 
into the hierarchy tab:
Gameplay_Scene , 
Procedural 
Zone_01
 Zone_02 
Zone_03 
Zone_04
Zone_05
Zone_06
Zone_07
Zone_08
Zone_09

3 In hierarchy tab drag drop the contents of the 
Gameplay_scene, Procedural, Zone_01 to 
Zone_09 into Combine scene



4 In the Hierarchy tab, click on the 3 dots icon 
next to scene Combine

5 Choose Save Scene

Caution: 
-Don’t choose Save All 
-Don’t use shortcut CTRL+ S

6 In the Hierarchy tab, click on the 3 dots icon 
next to scene Gameplay_Scene

7 Choose Remove Scene

A new window appears

8 Press Don’t Save button

9 In the same way remove scenes:
Procedural, Zone_01 to Zone_09.

The scene Combine is ready to use.

Important:
Don’t forget to recalculate the lightmaps if you 
need it.



14 Compute lightmaps manually

When using additive scenes, you have to calculate the lightmaps for each scene separately. 
The lightmaps are recombined automaticaly afterwards when all the scenes are put into the 
hierarchy tab.

A script is included in the asset to easily calculate lightmaps with additives scenes.
If you want to learn more about calculate lightmaps script : L  ink  

Calculating lightmaps without the script can be tedious, which is why it is better to use the script.

But whatever the reason, if you prefer to calculate lightmaps without the script follow this tutorial:

In this tutorial we will combine lightmaps from 2 
different scenes. These 2 scenes use the same 
lighting.

1 In Project tab double click on 
Tuto_CalculateLighmaps scene to open it 
 

Assets > HPA > Scenes > Tuto > 
Calculate_Lightmaps > Tuto_CalculateLighmaps

2 From Project tab drag and drop 
Tuto_CalculateLighmaps_01 in the hierarchy 
tab:

Assets > HPA > Scenes > Tuto > 
Calculate_Lightmaps > Tuto_CalculateLighmaps_01

3 From Tuto_CalculateLighmaps scene drag and 
drop SUN_Directional_Light to 
Tuto_CalculateLighmaps_01 scene 



4 In hierarchy tab select Tuto_CalculateLighmaps 
scene

-Mouse right click
-Choose Remove Scene 

A new window appears

5 Press Don’t Save button

6 Go to Window > Rendering > Lighting 

-In Lighting tab:
Press Generate Lightmaps

7 When lightmaps calculation is Done:

Use keyboard shortcut Ctrl + S to save the 
scene

8 From Project tab drag and drop 
Tuto_CalculateLighmaps_02 in the hierarchy 
tab:

 Calculate_Lightmaps > Tuto_CalculateLighmaps_02



9 From Tuto_CalculateLighmaps_01 scene drag and
drop SUN_Directional_Light to 
Tuto_CalculateLighmaps_02 scene 

10 Ctrl+S to save all scenes

11 In hierarchy tab select 
Tuto_CalculateLighmaps_01 scene
-Mouse right click
-Choose Remove Scene 

12 Go to Window > Rendering > Lighting 

-In Lighting tab:
Press Generate Lightmaps

13 Delete SUN_Directional_Light
-Use keyboard shortcut Ctrl + S to save the scene



14 Go to Window > Rendering > Lighting 

-In Lighting tab:
Open BakedLighmaps tab (spot 1)

Lightmap of scene Tuto_CalculateLighmaps_02
is displayed (spot 2)

15 From Project tab drag and drop 
Tuto_CalculateLighmaps_01 scene in the 
hierarchy tab:

Assets > HPA > Scenes > Tuto > 
Calculate_Lightmaps > Tuto_CalculateLighmaps_01

In the lighting tab we can see the 2 lightmaps 
that correspond to the 2 scenes (cube and  
sphere).

16 To add Directional Light(Sun) in the scene:
From Project tab drag and drop 
Tuto_CalculateLighmaps in the hierarchy tab



15 How to load the playground from a Menu Scene

Note: This section is designed to be read from 
the start to the end.

In most case it is useful to have a main menu scene in a 
game.

This section explains how to load the 
playground (Gameplay scene + All Zone 
scenes) from a Menu Scene.

How it works:

In a Menu scene:
When the player presses the Start Game 
Button.

The Load Additive scene is loaded and the 
scene Menu Scene is destroyed.

Then Load Additive scene loads all the 
Game Scenes.

When all the scenes are loaded, Load Additive scene is 
destroyed.

When the player want to go back to the Menu 
scene: the player presses P key.



How to setup a button in the Menu scene to 
load the game

As an example a Menu scene is available in the
asset.

Open the scene MainMenu.

Assets > HPA > Scenes > MainMenu 

In the MainMenu scene we have LoadManager 
object that contains:

- A script to load the game (spot 1).

- A button that call the method to load the game 
(spot 2)

-Select Button_Start in the Hierarchy (spot 1).

Canvas > Images > Button_Start

In Inspector tab:

When the player click on the button:

The method LoadASceneAsync (spot 2)
attached to LoadManager object is called (spot 
3)

The method LoadASceneAsync allows to load a
scene.

In our case it loads the scene named 
LoadAdditive
(spot 1).



IMPORTANT: You MUST use the name of a 
scene available in your build.

(File → Build Settings)

In build settings window:

Your scene MUST be set into the list 

IMPORTANT: The name you write in the field 
(spot 1) MUST be exactly the same as the 
name of your scene.

If there is an error in the name the scene won’t be load.

- Press Play to start the game.

- Press the button.

LoadAdditive is loaded and MainMenu scene is destroyed.

When LoadAdditive starts it automatically loads all the 
scene needed for the game.



When all the gameplay scenes are loaded:

LoadAdditive scene is destroyed automatically.

- Press Stop to stop the game.

Now we are going to add a prefab in the 
Gameplay_Scene that allows the player to go 
back to the Menu Scene.

To be able to load the Menu scene we MUST 
add the scene to the Scenes in Build list.

(Go to: File → Build Settings)

-Add the MainMenu scene at the beginning of 
the list.

Important:
MainMenu must be added first into the list.
The first scene in the list is automatically loaded when the 
game starts.

-Open the Gameplay_Scene.

-From project tab drag and drop 
GoToMainMenu prefab in the Hierarchy.

Assets > HPA > Scripts > InitManager > 
MainMenuExample > GoToMainMenu



GoToMainMenu object contains 2 scripts (spot 
1):

- LoadAScene.cs (spot 2). 
It contains the method to load a scene.

- GoToMainMenu.cs (spot 3). 
This script has a method to check if the player 
presses P key.
When P key is pressed, the LoadAScene.cs is 
called to load the Main Menu scene.
 

- Save the Gameplay_Scene (CTRL+S)

- Open the scene MainMenu.

Assets > HPA > Scenes >  MainMenu 

- Press Play to start the game.

- Press the button.

LoadAdditive is loaded and MainMenu scene is destroyed.

When LoadAdditive starts it automatically loads all the 
scene needed for the game.

When all the gameplay scenes are loaded:

LoadAdiitive scene is destroyed automatically.

- Press P key.
The Main_Menu scene is loaded. Other scenes are 
destroyed.

- Press Stop to stop the game.



16 Adapt the initialization of the Gameplay_Scene 
to your game

Note: This section is designed to be read from 
the start to the end.

In most case it is important to have the control on the 
initialization of your game.
It is useful to know when the initialization starts and when 
all the modules of your scene are initialized.
When everything is initialized in the scene, the player can 
start playing the game.

The asset contains a system to help you during the 
initialization phase.
If you don’t want to use this system it possible to remove 
the InitManager object from the Hierarchy.

This section explains how to do actions during 
the initialization of the game.

For example: This system is useful if you want 
to disable the character until all the game 
initialization are done.

As an example: In the demo scene
When the scene starts: 

- A loading screen is displayed.
- The character movement is disabled.

Then when the optimization system is initialized:
- The loading screen is disabled.
- The character movement is enabled. 

This chapter explains how to customize the 
object InitManager in your Gameplay scene to 
fit your game needed.

Summary:

- How it works Link

- Do something when the scene starts Link

- Wait until something is done Link

- Do something when the game is initialized Link



- Special case: The character is not contained in
the Gameplay_Scene.
The character is instantiated manually in the scene

(Example: 
The scene starts
then the character is instantiated in the scene manually. 

In that case you need to load your character then you 
need to initialize the grid optimization system depending 
the position of the character in the scene. This chapter 
explains what to do in that case)

Link

How it Works

In the Gameplay_Scene the object InitManager 
allows:

- To do actions when the scene starts.
- Wait until the scene is initialized.
- To do something when the game is initialized.

Note: It is possible to delete InitManager object 
if you don’t want to use this system.

In the Inspector:
- Section Action When Scene Starts allows to 
calls methods when the game starts.

By default a method is called to displayed the loading 
screen and disabled the character movement.

- Section Wait Until List is used to check if all 
the process of the game initialization are done.

By default this section check if the system to optimize the 
scene has finished its initialization.

- Section Action When Init Process Done allows 
to calls methods when all the process of the 
game initialization are done.

By default a method is called to disabled the loading 
screen and enabled the character movement.



Do something when the scene starts

This section explains how to call your own 
methods when the Gameplay_Scene starts.

As an example we are going to call a method 
that display “Gameplay scene starts” in the 
console tab.

-In the Gameplay_Scene select the object 
InitManager
(hierarchy tab: Manager → InitManager)

-In the inspector press the triangle button to 
open the section ActionWhenSceneStarts 

By default there are 2 methods already setup:
A method is called to displayed the loading screen 
(green square).
A method disabled the character movement (blue square).



-At the end of the list press the + button (spot 1)

A new slot is created.

Now we are going to drag and drop the object in
the hierarchy that contained the method we 
want to use.
(spot 1).

Then we are going to choose the method to call 
(spot 2)

Very Important:
The object you drag and drop MUST be in the 
scene Gameplay_Scene.

The methods we are going to use for this 
example are contained in the object 
InitManagerExample.



-Drag and drop InitManagerExample object 
inside the new slot (spot 1)

-Choose the method 
DisplayTextWhenSceneStarts in the dropdown 
menu (spot 2)
(InitManagerExample →  DisplayTextWhenSceneStarts() )

- Press Play to start the game.

 The text is displayed in the console tab when the scene 
starts.

- Press Stop to stop the game.

Wait until something is done

Section Wait Until list is used to checked if all 
the process of the game initialization are done.

By default Wait Until list verifies that grid 
optimization is completed.

As an example we will also check if toggle is 
true

Toggle is inside InitManagerExample object 
(spot 1)

As a consequence, the InitManager object will 
return that the scene is initialized when:
-The Optimization system is initialized(by 
default).
And



-Toggle boolean is set to true.

Both conditions must be met to continue.

- In the Gameplay_Scene select InitManager 
(spot 1)
(Hierarchy: Manager → InitManager)

- Press the triangle next to Wait Until List to 
opened the section (spot 2).

- Press + button (spot 3) to add a new slot. 

-inside the new slot drag and drop the 
InitManagerExample object.

- Press Play to start the game.



The loading doesn’t disappear.

In hierarchy tab:
- In the Gameplay_Scene select 
InitManagerExample (spot 1)
(Hierarchy: Manager → InitManager → 
InitManagerExample)

- In the Inspector check Toggle variable.

The loading screen disappear.

- Press Stop to stop the game.

Very Important:

The object you drag and drop: 

- MUST be in the scene Gameplay_Scene.

- MUST have a script attached to it that access 
the Interface HP.Generics.IInitable and a 
boolean method named IsInitDone() 

In the next section we will see how to setup a 
script.



This section is finished so don’t forget to 
remove the example.

- In the Gameplay_Scene select InitManager 
(spot 1)
(Hierarchy: Manager → InitManager)

- In section Wait Until List press - button (spot 2)
to remove InitManagerExample object from the 
list. 



How to setup a script to be used in the 
WaitUntilList section

How WaitUntilList section works:

Each object in WaitUntilList has a script 
attached to it that contained a boolean method 
named 
IsInitDone(){} (spot 1a, 1b)

For each object inside WaitUntilList the script 
InitManager check if all IsInitDone(){} methods 
return True.

When all the methods return True the 
InitManager script call the methods included in 
the section ActionWhenInitProcessDone (spot 
2).

 

How to create your own IsInitSection(){} 

As an example to show how to create your own 
IsInitSection(){} we will see the example from 
the previous section.

In the previous section we added 
InitManagerExample object to the WaitUntilList



InitManagerExample object has 
InitManagerExample.cs script attached to it 
(spot1).

Inside the script:
- The interface HP.Generics.IInitable is listed 
after MonoBehaviour inheritance (spot 1).

In your script you must listed this interface after 
any inheritance of your script. Use comma to 
separate the 2 inheritances.

-The boolean method IsInitDone() is declared 
at the end of the script (spot 1).

In your script you must declare this method.

You can write your own code to return the state 
of the initialization for this object.

Important:
The object MUST have only ONE script with the
Interface HP.Generics.IInitable connected to it.



Do something when the game is initialized

This section explains how to add your own 
methods when the scene is initialized.

As an example we are going to call a method 
that display “Gameplay scene is initialized” in 
the console tab.

-In the Gameplay_Scene select the object 
InitManager
(hierarchy tab: Manager → InitManager)

-In the inspector press the triangle button to 
open the section ActionWhenInitProcessDone

By default there are 2 methods already setup:
A method is called to disable the loading screen 
(green square).
A method enabled the character movement (blue square).

-At the end of the list press the + button (spot 1)

A new slot is created.



Now we are going to drag and drop the object in
the hierarchy that contained the method we 
want to use.
(spot 1).

Then we are going to choose the method to call 
(spot 2)

Very Important:
The object you drag and drop MUST be in the 
scene Gameplay_Scene.

The methods we are going to use for this 
example are contained in the object 
InitManagerExample.

-Drag and drop InitManagerExample object 
inside the new slot (spot 1)

-Choose the method 
DoSomethingWhenSceneIsInitialized in the 
dropdown menu (spot 2)
(InitManagerExample → 
DoSomethingWhenSceneIsInitialized() )

- Press Play to start the game.



 The text is displayed in the console tab when the scene is
initialized.

- Press Stop to stop the game.

Special case: The character is not contained 
in the Gameplay_Scene.
The character is instantiated manually in the scene

Case: 
There is no character in the Gameplay_Scene.
The character is instantiated by script in the 
scene. 

(Reminder: The character must have the script 
TSCharacterTag attached to it. This script is used by the 
optimization system to know the position of the character. 
This is the reason why we need to be sure the character is
loaded in the scene before we try to initialized the 
optimization system.)

In that case: 
- You need to load the character in the scene.
- Then you need to initialize the grid 
optimization system depending the position of 
the character in the scene. 

This chapter explains what to do in that case. Each game 
is different so you probably need to adapt the example to 
your game.



The steps we need to do:

Disabled the auto initialization of the 
Optimization system.

- In Gameplay_Scene select GridOptimization 
(spot 1) (Hierarchy: Manager → GridOptimization)

- In the Inspector uncheck 
IsInitializedWhenSceneStarts (spot 2)

Now we can initialize the object when we want by script.

Remove the character from the Hierarchy

- In the Gameplay_Scene delete 
Grp_CharacterCamera 
(spot 1) (Hierarchy: Manager → Grp_CharacterCamera)

Setup the scene for the new character

For this example:

- In the Gameplay_Scene drag and drop the 
OptiGridAndPlayer prefab.

(Project Tab: Assets → HPA → Scripts → InitManager → 
CharacterExample → OptiGridAndPlayer)

The object contains: 
-The character camera.



- OptiGridAndPlayer prefab has also a script 
attached to it.

The OptiGridAndPlayer.cs script contains the 
methods to: 

- Load the character when the scene starts 
(spot 1).
(When the scene starts the script automatically load the 
character in the scene)

- Connect automatically the camera to the 
character (spot 2).

- Start manually the initialization of the 
optimization system when the character is 
loaded in the scene (spot 3).
use the method 
HP.Generics.TSOptiGrid.instance.Init();

- Check if the optimization system is initialized 
(spot 4).

Setup InitManager object

(more info about InitManager in the previous sections)

InitManager allows to check if some scripts are 
initialized in the scene.

In our case we want to check if:
- The player is loaded and moved to its default 
position.
- The Optimization system is initialized.



To do that we are going to use the method 
IsInitDone()  from the interface IInitable 
(more info about how to setup the interface in the previous
sections)

This method return if the Optimization system is 
initialized.

- In the Gameplay_Scene select InitManager 
(spot 1)
(Hierarchy: Manager → InitManager)

- Drag and drop OptiGridAndPlayer object 
inside 
Wait Unitl List slot Element 0 (spot 2)

Now the method IsInitDone()  from the 
interface Iinitable is checked to know if the 
initialization of the scene is done.

- Press Play to start the game.

The loading screen is displayed 
Then the player is loaded in the scene.
Then the optimization system is initialized
Finally the loading screen is disabled.

- Press Stop to stop the game.



17 Troubleshooting

Console Warning :
The type or namespace name universal does not exist

This means that URP Package is not installed.
If you do not have URP installed, other error messages may appear in the console. Install URP to make console errors 
disappear.

All shaders are pink

This means that URP Package is not installed or configured correctly.
Install URP to solve the problem

For more information L  ink  

The textures of roads and pathroads does not integrate well with the textures of the ground

You must calculate lightmaps of Procedural Scene.
To learn how to calculate lightmaps Link

Snap is not working

To learn how to use snap L  ink  

Building lighting doesn't look right, reflections look weird, or the building doesn't look well 
integrated with the terrain:

-Check if the reflection prob encompasses the whole building
-Check that the center of the reflection is inside the building

For more informations about Reflection probs L  ink  

Lods prefabs disappear too close to the camera

-Set Lod Bias to 3 
For more informations L  ink  

During the game, some objects do not appear or appear / disappear at the wrong moment

T  ry these different solutions:  

-Set Lod Bias to 3. For more informations L  ink  

-To determine the distance, the optimization system takes into account the center of the group. 
Check that the center of the group. For more informations L  ink  
-Set up GridOptimization row and columns. For more informations L  ink  
-Set up Distance Min. For more informations L  ink  
-Set up  Ref Distance Per second. For more informations about optimization system L  ink  

Road doesn’t work correctly

If roads are included in a group:

Set group to: 
Position 0 0 0    Rotation 0 0 0     Scale 1 1 1



I can't draw the points to create a road

To solve this problem: 
-Verify that gizmos are activate in scene tab
-In scene view select the terrain
-In hierarchy tab select again the new Road
-Press keyboard shortcut N

For more informations L  ink  

When I work in scene view, it's slow

Do not display the scene view and the game view at the same time

Console Warning :
Cross scene references are not supported

This warning appears when working with several scenes in the hierarchy tab (scene additives).
Do not take this warning into account.

Console Warning : 
There are x objects in the scene with overlapping Uv’s

Do not take this warning into account: it has no impact on rendering quality or performance.

There are invisible colliders on terrain:  

After creating roads you must delete roads colliders

For more informations L  ink  

Console Warning :
InitializeLighmapData job with hash .... exit code 2  

This means that there is not enough RAM to calculate the lightmaps

To solve the problem:

-Cut the scene into 2 scenes to reduce the number of objects to calculate. For more informations 
how to work with additives scenes L  ink  

or

-Reduce the number of prefabs into the scene

Build is stuck at 100% and won't start

You must put in the build all the scenes indicated in the LoadAdditive scene

For more information L  ink  

Issue: at the bottom right in the unity editor: grey bar blocked once the lightmap calculation is 
complete.

For more information Link
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